PDFE Reader Controller

1. Introduction

Author: SkySof Software Inc. at http://www.skysof.com
Download URL: http://www.qgetfilez.com/pdfrdr.zip

PDF Reader Controller is a Window’s Service that runs in the background which controls access to specific
windows and menus in Adobe Reader versions 9 and 10 (X). With PDF Reader Controller it is not necessary to
password-protect your PDF files! Simply specify which PDFs files a machine cannot open via a list of file
specifications (example: p*.pdf, s???.pdf) and PDF Reader Controller will prevent a user from opening them.
Other features of PDF Reader Controller include:

Prohibit copying of PDF text

Prohibit access to the Toolbar

Prohibit access to the File Menu

Prohibit access to the Edit Menu

Prohibit access to the Document Menu

Prohibit access to the Tools Menu

Prohibit access to the View Menu

Prohibit access to the Help Menu

Prohibit access to the Bookmark Popup Menu (to prevent printing the PDF)
Prohibit access to the Page Popup Menu

Prohibit access to the Print Dialog Window (to prevent printing the PDF)
Prohibit access to the Document Properties Dialog

Prohibit access to the Page Display Preferences Dialog Window

Prohibit access to the Save As Dialog Window (to prevent saving the PDF file)

2. Installation and Configuration

a. Unzip file PDFRDR.ZIP into a folder on your local drive such as C:\TEMP
b. Run SETUP.EXE to install. Click the Next button.

Welcome to the PDF Reader Controller Setup

Wizard

The inztaller will guide you through the steps required to install PDF Reader Controller on pour

computer.

WARMIMNG: This computer program is protected by copyright law and international treaties.
Unauthorized duplication or distibution of this program, or any portion of it, may result in severe civil
or criminal penalties, and will be prosecuted to the maximum extent possible under the law.

Cancel < Back



http://www.skysof.com/
http://www.getfilez.com/pdfrdr.zip

c. Leave the default settings as they are and click the Next button.

i'-.%l‘ PDF Reader Controller

Select Installation Folder

The inztaller will install POF Reader Contraller to the following folder.

Toingtall in this folder, click "Mext”. To ingtal to a diffterent folder, enter it below or click "Browse''.

Folder:
C:A\Program FileshSkySof Software IncWPDF Reader Controller, Browsze. |

DiskCost. |

Ihstall PDF Reader Cantraller for yourself, or for anyone who uzes this computer:

' Everyone

 Just me

Cancel < Back

d. Click the Next button.

i'.é'u PDF Reader Controller ;IEIE'

Confirm Installation

The ingtaller iz ready to inztall FDF Reader Controller on your computer.

Click "Mext" to start the inztallation.

Cancel < Back




e. If the installation was successful you will see this screen. Click the Close button to exit.

i'.‘% PDF Reader Controller

Installation Complete

PDF Reader Controller haz been successfully installed.

Click "Cloze" to exit.

Fleaze use Windows Update to check for any critical updates to the MET Framewark.

Cancel | < Back |

f.  The next step is to configure PDF Reader Controller. To run the configuration application run
C:\Program Files\SkySof Software Inc\PDF Reader Controlle\CONFIGURE.EXE

onfigure PDF Reader Controller

[~ General Settings

I Dizplay a message boxwhen a menu is blocked I Dizplay a window behind the message box | Dizplay a non see-through window
Prevent opening POF files with theze file zpecifications (examples: p*.pdf: £777.pdf) . Separate multiples with semi-colons

| Clear All
Disable toolbar for PDF files with these file specifications (examples: p™.pdf; s777.pdf) . Separate multiples with semi-colons

[ p

Dizable copving of page text for POF files with these file specifications (examples: p*.pdf; 777 pdf) . Separate multiples with zemi-colons
[ p

Req File

Cancel

fElil,

[~ Select Menus to dizable

Disable Menu for PDF files with these file specifications (examples: p*.pdf: 777.pdf) . Separate multiples with semi-colons
File I*_pdf

Edit [*.p

Docurrent I*-Ddf

Toals I*.pdf
Wiew I*-Ddf
Help [

[ Select Popup Menus to disable

Dizable Popup Menu for PDF files with these file specifications (examples: p* pdf; 2777 pdf) . Separate multiples with semi-colons
Bookemark |* pdi

Left Pane |* pdi

Fage I* pdi

~ Belect Dialog Windows to disable

Dizable Dialog Window for PDF files with theze file zpecifications (examples: p*.pdf: £?77.pdf) . Separate multiples with semi-colons

Print I*-Ddf
Document Properies I*-Ddf
Save a CopwSave As I*-Ddf

Page Display Preferences I*-Ddf




g. In the first text box labeled “Prevent opening PDF files” enter p*.pdf and leave all the other settings as
is then press the OK button to save the settings in the Window’s Registry. Click the Cancel button to
close the application.

Prevent opening PDF files with theze file specificationz
Ip*.pu:lf

h. The next step is to configure the PDF Reader Controller Window’s Service. Click the Start button and
select Control Panel > Administrative Tools > Services. Another way to open the Window’s Services
screen is to click the Start button then select Run... and type in services.msc

Run 2|

— Type the name of a program, Folder, document, or
5 Inkernet resaurce, and \Windows will open it Far yau,

=8 SEFVICES . MST e I

5

K I Cancel | Browse, ., |

i. The Window’s Service screen looks similar to this:

5y Gervices O] x|

File  Action Yiew Help

“'"’|||E>|@|F r m Il =

cal) Services (Local)

Select an item to view its description, Mame A I Descl AI
\MET Runtime Opki,..  Micra

%Adnbe LM Service Hdol

4 Alerter MatiFi
%.ﬁ.pplicatiun Layer G... Prowvi
%.ﬁ.pplicatiun Manage... Prowvi
884 ASP.NET State Ser...  Pravi
%.ﬁ.utnmatic Updates  Enab
%Backgmund Intellig... Tram:
%Clipﬁnnk Enab
%CONH Event Swstem  Supp
%CONH System Appl... Manz
%Cumputer Browser Maint
%Cryptagraphic Sery,.. Prowvi

-
ﬁnrﬁm n:rmm D D
4 3

Extended ,.-{ Standard ,.I"




J. Scroll down the list of services and search for the service named PDF Reader Controller.

4 Seryices

Eile Action Mew Help

=101 x|

> |EFER|2E[> = I =

% Services (Local)

Services (Local)

PDF Reader Controller Mame 7

& Dortable Madia Serial b

Start the service MV IDIA Displary Driver .,

S aCC.,

Description: *POF Reader Conkraller
Controls access to spedfic windows in %Performance Logs and ...
Adobe Reader, %Plug and Play

Aukomatic Local ]
Collects perf. .. TManual Metwork 5.
Enables aco...  Started Aukomatic Local System
Dabriawec th Mannal | al Swckam

| Descripkion | Skatus | Skartup Tyvpe | Log On As | :I
MT LM Security Suppor...  Provides sec.., Manual Local System
Provides sys...  Started Aukomatic Local System

%Office Source Engine Saves install... Manual Local Swstem |

Extended A Standard /

k. Right-click on this service to invoke the popup menu and select Properties. The Properties Window

should look like this:

PDF Reader Controller Propetties {Local Comp |

General |L|:|g EInI Heu:u:uver_l,ll Dependenciesl

Service name; PDFReaderController

POF Beader Contralle

Dizplay name:

Controls access to specific windows in Adobe ﬂ

Reader. ll

Dezcription:

Fath to executable:

"C:AProgram Files'SkySof Software IncPDF Reader ControllertsPOFR eade

Startup tupe: Autarnatic j

Service statuz: Stopped

Start | Stop | Pauze Hesume |
f'ou zan zpecify the start parameters that apply when pou start the zervice
from here.

Start parameters: I

0k, I Cancel Spply




I. Click on tab Log On and select “Allow service to interact with desktop” then click the Apply button to
save the change.

PDF Reader Controller Properties (Local Compute ed |

General LogOn I Flecm-'er_ul Dependenciesl

Log on as:

& |ocal System account

[ v llow zervice b interact with deskbops ]
¢~ This account: I Erowsee... |
Eazzward: I

Lanfim passward: I

r'ou can enable or dizable thiz zervice for the hardware profiles listed below:

Hardware Prafile | Service |
Profile 1 Enabled
Ensble | Disable |

(1] 4 I Cancel |[ Apply |

m. Click on tab Recovery and change setting to “Restart the Service” for failures. Click the OK button to
save the changes.

PDF Reader Controller Properties {Local Compute e |

Generall LogOn Recovery | Dependenciesl

Select the computer's response if this service fails.

First failure: IHestart the Service j
Secaond failure: IFEestart the Service j
Subzequent failures: IHestart the Service j
q | w—

Reset fail count after: 1t days
Restart zervice after: |1 minutes
- BLim pragranm

Eragrar

I Browse,.. |

Lammand line parameters:

[T &ppend faillcount to end af commarnd line (/=515

FEestart Computer Dptiong...

0k, I Cancel | Anply I




n. Now the service is ready to be started. Right-click on this service to invoke the popup menu and select
Start. If the service started successfully you will see “Started” in the Status column.

%, Services -0l x|

File  Action  Miew  Help

o |mFER2E > = 0w

% Services (Local) 8. Services (Local)
PDF Reader Controller Mame  # | Descripkion | Skatus | Stattup Type | Log On As | ;l
-~ %NT LM Security Suppor...  Provides sec... Tanual Local System
Stop the service %NUIDIA Display Driver ... Provides sws,,,  Starbed Automatic Local System

Pause the service
Restart the service

%Office Source Engine Saves install... IManual Local Syskem o

e *PDF Reader Contraller Controls ace,.,  Skarked Bukormnatic Local Syskerm
i ————————
%Performance Logs and ... Collecks perf..T Aanual Metwark 5.,
Description: %Plu d .
e g and Play Enables a co...  Started Aukomatic Local System
Controls access to SFIEDﬁC windows in LI %Dnrl‘ahlp Media Serial bl B etricwes Fh Flam sl L mal Swezkemn ll

.Extenaed A Standard /£

0. Test the service by attempting to open a PDF file that begins with the letter P. Recall that in step G
above the service to block the opening of all PDF files beginning with the letter P. Try opening
C:\Program Files\SkySof Software Inc\PDF Reader Controller\PDFRDR.PDF. You should not be able
to open it.

p. Test the other operations of the service by opening any PDF file and attempting to access the menus,
popup menus and dialog windows. You can pause the service at any time and make changes using
C:\Program Files\SkySof Software Inc\PDF Reader Controlle\CONFIGURE.EXE then resume the
service. By following file naming conventions with your PDF files you can enable or disable access to
specific features in Adobe Reader. For example: by preceding your PDF files with MGR_ you can
restrict access to these files to managers only. Some sample file names could be MGR_Budget.PDF or
MGR_Sales.PDF. For non-manager machines you would set the file specification in step G above to
mgr_*.pdf to prevent the user from opening these files.

If you are interested in a Window’s Service that prohibits access to features in Foxit Reader, PDF-Xchange or
any other PDF reading program please send an email to Frank at Kusluski@nc.rr.com

3. Configuring on Many Machines

If you intend to install PDF Reader Controller on many machines that will have the same settings you can create
a Window’s Registry File (REG) that can be copied to the machine then executed. Doing so will greatly ease
installation on multiple machines. To do so run C:\Program Files\SkySof Software Inc\PDF Reader
Controlle\CONFIGURE.EXE, make changes, then click the “Reg File” button to create the Window’s Registry
File named CONFIG.REG. You should see the following screen:

x

\lj) Regisktry File C:\Program Files\SkySof Software InciPOF Reader Controller COMFLG.REG saved,



mailto:Kusluski@nc.rr.com

Next, copy file C:\Program Files\SkySof Software Inc\PDF Reader Controlle\CONFIG.REG to the target
machine and then double-click on the file to run and import settings into the Window’s Registry.

Registry Editor x|

:{J Are you sure you want to add the information in C:\Program Files!Sky3of Software InciPOF Reader ControllerhCOMFIG.REG to the registry?

Mo
Click the Yes button.
x|

\l;) Information in C:\Program Files)SkySof Software InciPOF Reader Contraoller, CONFIG.REG has been successfully entered inko the registry,

4. Pricing

The trial version of PDF Reader Controller expires after 30 days. If you are interested in purchasing the

registered version with no expiration please go to:

https://www.regnow.com/checkout/product/4459-66

The price of PDF Reader Controller per machine depends on the quantity ordered. The greater the quantity
ordered the lower the price will be per machine. Please see table below for more detail. All amounts are in US

dollars.

Cost per Machine Quantity
$49.95 1to 100
$39.95 101 to 200
$29.95 201 to 500
$19.95 501 to 1000

$14.95

1001 or more



https://www.regnow.com/checkout/product/4459-66
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